Παρασκευή, 15 Δεκεμβρίου 2017

Υπολογίζοντας τα έξοδα

Βαθμός Δυσκολίας:
2/5
Εκφώνηση Ασκησης: 

Η μητέρα Ολγίτσα θέλησε να αξιοποιήσει τις γνώσεις του παιδιού της στην πληροφορική, για να υπολογίζει εύκολα κάποια στοιχεία εξόδων κάθε φορά που πηγαίνει για ψώνια. Για να τη βοηθήσουμε, θα χρειαστεί να γράψουμε αλγόριθμο, ο οποίος:

α) θα διαβάζει το όνομα και τη τιμή για κάθε προϊόν. Η διαδικασία θα συνεχίζει μέχρι να δοθεί σαν όνομα το "Ουφ τέλος τα έξοδα για σήμερα!".

β) να εμφανίζει το σύνολο των χρημάτων που ξόδεψε.

γ) να εμφανίζει το όνομα του προϊόντος  για το οποίο ξόδεψε τα περισσότερα χρήματα.

δ) να εμφανίζει το ποσοστό των προϊόντων που έχουν τιμή κάτω από 3 euro.

Επιμέλεια: mstamos.gr

Λύση Άσκησης: 

 

Αλγόριθμος Μητέρα_Ολγίτσα
 
Εμφάνισε "Δώσε το όνομα του προϊόντος."
Διάβασε προϊόν
!Χρησιμοποιούμε εδώ την "αν" σε περίπτωση που θέλουμε ο αλγόριθμος να τερματίσει από το πρώτο προϊόν
Αν προϊόν ≠ "Ουφ τέλος τα έξοδα για σήμερα!" τότε
  Εμφάνισε "Δώσε την τιμή του ", προϊόν
  Διάβασε τιμή
 
!Αρχική τιμή στο ΜΑΧ
  ΜΑΧ_τιμ ← τιμή
  ΜΑΧ_πρ ← προϊόν
αλλιώς
  τιμή ← 0
Τέλος_αν
!Αρχικοποίηση των μεταβλητών
συν_εξόδων ← 0
συν_πρ ← 0
πλ_πρ ← 0
 
Όσο προϊόν ≠ "Ουφ τέλος τα έξοδα για σήμερα!" επανέλαβε
!Ερώτημα β
  συν_εξόδων ← συν_εξόδων + τιμή
!Ερώτημα γ
  Αν τιμή > ΜΑΧ_τιμ τότε
    ΜΑΧ_τιμ ← τιμή
    ΜΑΧ_πρ ← προϊόν
  Τέλος_αν
!Ερώτημα δ
!Για να υπολογίσουμε το ποσοστό των προϊόντων κάτω από 3 ευρώ θα χρειαστούμε το πλήθος των προϊόντων κάτω από 3 ευρώ καθώς και το συνολικό πλήθος των προϊόντων που αγόρασε.
  Αν τιμή < 3 τότε
    πλ_πρ ← πλ_πρ + 1
  Τέλος_αν
  συν_πρ ← συν_πρ + 1
 
!Δεν ξεχνάμε όταν χρησιμοποιούμε τιμή φρουρό να ξαναδιαβάζουμε τα στοιχεία μας λίγο πριν κλείσει η επανάληψη ώστε να τερματίζει ο αλγόριθμό μας.
  Εμφάνισε "Δώσε το όνομα του προϊόντος."
  Διάβασε προϊόν
  Αν προϊόν ≠ "Ουφ τέλος τα έξοδα για σήμερα!" τότε
    Εμφάνισε "Δώσε την τιμή του ", προϊόν
    Διάβασε τιμή
  Τέλος_αν
Τέλος_επανάληψης
 
Αν τιμή ≠ 0 τότε
  Εμφάνισε "Το σύνολο των χρημάτων που ξόδεψες είναι ", συν_εξόδων
  Εμφάνισε "Το προϊόν για το οποίο ξοδέψες τα περισσότερα είναι ", ΜΑΧ_πρ
  ποσ_πρ ← πλ_πρ/συν_πρ* 100
  Εμφάνισε "Το ποσοστό των προϊόντων που έχουν τιμή κάτω από 3 euro είναι ", ποσ_πρ
Τέλος_αν
 
 
Τέλος Μητέρα_Ολγίτσα