Παρασκευή, 15 Δεκεμβρίου 2017

Scouter Βόλεϊ

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

Ένας scouter νέων παιχτών βόλεϊ σας ζητά να του γράψετε το εξής πρόγραμμα:

  1. Να περιέχει τμήμα δήλωσης μεταβλητών.
  2. Να διαβάζει τα ονόματα, τους πόντους και τον χρόνο συμμετοχής για κάθε ένα αθλητή από τους 60 που έχουν επιλεγεί απ' όλη την Ελλάδα.
  3. Να υπολογίζει και να εμφανίζει:
    1. Tο όνομα του παίχτη με το μεγαλύτερο πλήθος πόντων και το όνομα του παίχτη με το μικρότερο χρόνο συμμετοχής.
    2. Το μέσο όρο των πόντων όλων των παιχτών.
    3. Το πλήθος των παιχτών που πέρασαν τους 10 πόντους.
    4. Το ποσοστό των παιχτών που είχαν χρόνο συμμετοχής μεγαλύτερο από 30 λεπτά.

Επιμέλεια: Διαμαντίδης Γιάννης

Λύση Άσκησης: 

 

ΠΡΟΓΡΑΜΜΑ scouter_volley
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ποντ, συμ, ΜΑΧ, ΜΙΝ, πλ_10, πλ_30_συμ, συν_ποντ
  ΠΡΑΓΜΑΤΙΚΕΣ: ποσοστο_30_συμ
  ΧΑΡΑΚΤΗΡΕΣ: ον, ον_ΜΙΝ, ον_ΜΑΧ

ΑΡΧΗ
  πλ_30_συμ ← 0
  πλ_10 ← 0

  συν_ποντ ← 0

  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 60
    ΓΡΑΨΕ 'Δώσε το όνομα του αθλητή'
    ΔΙΑΒΑΣΕ ον
    ΓΡΑΨΕ 'Δώσε τους πόντους'
    ΔΙΑΒΑΣΕ ποντ
    ΓΡΑΨΕ 'Δώσε χρόνο συμμετοχής'
    ΔΙΑΒΑΣΕ συμ
    ΑΝ ι = 1 ΤΟΤΕ
      ΜΑΧ ← ποντ
      ον_ΜΑΧ ← ον
      ΜΙΝ ← συμ
      ον_ΜΙΝ ← ον
    ΑΛΛΙΩΣ
      ΑΝ ποντ > ΜΑΧ ΤΟΤΕ
        ΜΑΧ ← ποντ
        ον_ΜΑΧ ← ον
      ΤΕΛΟΣ_ΑΝ
      ΑΝ συμ < ΜΙΝ ΤΟΤΕ
        ΜΙΝ ← συμ
        ον_ΜΙΝ ← ον
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

   συν_ποντ ← συν_ποντ + ποντ
    ΑΝ ποντ > 10 ΤΟΤΕ
      πλ_10 ← πλ_10 + 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ συμ > 30 ΤΟΤΕ
      πλ_30_συμ ← πλ_30_συμ + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΜΟ_Ποντ ← συν_ποντ/60
  ποσοστο_30_συμ ← (πλ_30_συμ/ 60)*100

  ΓΡΑΨΕ 'Ο Μέσος Όρος των πόντων όλων των παικτών είναι ', ΜΟ_Ποντ
  ΓΡΑΨΕ 'Ο αθλητής με τους περισσότερους πόντους είναι ο ', ον_ΜΑΧ
  ΓΡΑΨΕ 'Ο αθλητής με τον λιγότερο χρόνο συμμετοχής είναι ο ', ον_ΜΙΝ
  ΓΡΑΨΕ 'Το πλήθος των αθλητών που είχαν πάνω από 10 πόντους είναι ', πλ_10
  ΓΡΑΨΕ 'Το ποσοστό των αθλητών που είχαν πάνω από 30 λεπτά συμμετοχής είναι ', ποσοστο_30_συμ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ