Δευτέρα, 10 Δεκεμβρίου 2018

Ποδοσφαιρική ομάδα - Αναγέννηση Κολινδρού

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

 

Ο πρόεδρος της ποδοσφαιρικής ομάδας "Αναγέννησης" Κολινδρού θέλησε να βγάλει κάποια στατιστικά στοιχεία για την ομάδα. Γι' αυτό το λόγο ζητά από εσάς να του γράψετε έναν αλγόριθμο ο οποίος:

Α) να δέχεται τον αριθμό της φανέλας, τις συνολικές προσπάθειες και τα γκολ που πέτυχε καθένας απο τους 22 παίχτες της ομάδας

Β)  να υπολογίζει το ποσοστό ευστοχίας της ομάδας

Γ) το πλήθος των παικτών που πέτυχαν πάνω από 8 γκολ

Δ) να εμφανίζει τον αριθμό της φανέλας του πιο γκολτζή της ομάδας.  

Επιμέλεια: mstamos.gr

 

Λύση Άσκησης: 
 
Αλγόριθμος Αναγέννηση_Κολινδρού
 
συνολικές_προσ_ομ ← 0
πλ_8 ← 0
συν_γκολ ← 0
 
Για ι από 1 μέχρι 22
!Ερώτημα Α
  Εμφάνισε "Δώσε τον αριθμό της φανέλας σου"
  Διάβασε φαν
  Εμφάνισε "Δώσε το σύνολο των προσπαθειών σου για γκολ"
  Διάβασε συν_προσ
  Εμφάνισε "Δώσε το σύνολο των γκολ που πέτυχες"
  Διάβασε γκολ
 
!Ερώτημα Β
  συνολικές_προσ_ομ ← συνολικές_προσ_ομ + συν_προσ
 
  συν_γκολ ← συν_γκολ + γκολ
!Ερώτημα Γ
  Αν γκολ > 8 τότε
    πλ_8 ← πλ_8 + 1
  Τέλος_αν
 
!Ερώτημα Δ
  Αν ι = 1 τότε
    ΜΑΧ ← γκολ
    φαν_ΜΑΧ ← φαν
  αλλιώς
    Αν γκολ > ΜΑΧ τότε
      ΜΑΧ ← γκολ
      φαν_ΜΑΧ ← φαν
    Τέλος_αν
  Τέλος_αν
Τέλος_επανάληψης
 
ποσοστό_ευστοχίας ← συν_γκολ/συνολικές_προσ_ομ* 100
Εμφάνισε "Το ποσοστό ευστοχίας της ομάδας είναι ", ποσοστό_ευστοχίας
Εμφάνισε "Ο πιο γκολτζής της ομάδας είναι ", φαν_ΜΑΧ
 
Εμφάνισε "Το πλήθος των παικτών που έβαλαν πάνω από 8 γκολ είναι ", πλ_8
 
Τέλος Αναγέννηση_Κολινδρού