Παρασκευή, 07 Δεκεμβρίου 2018

Πίνακας Συχνοτήτων Ακεραίων Αριθμών

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

 

Να γραφεί αλγόριθμος ο οποίος να διαβάζει τους βαθμούς 100 μαθητών (οι βαθμοί είναι μεταξύ 1-20) και να να τους αποθηκεύει στον πίνακα Β[100]. Στη συνέχεια

α) να δημιουργεί πίνακα με τη συχνότητα του κάθε βαθμού που παρατηρείται όταν οι βαθμοί είναι ακέραιου τύπου (να γίνει έλεγχος καταχώρησης),

β) να εμφανίζει τον πίνακα αυτόν.

Επιμέλεια: mstamos.gr 

Λύση Άσκησης: 
 
Αλγόριθμος Πίνακας_Συχνοτήτων_Ακεραίων
 
! Αποθηκεύουμε τα στοιχεία που θα μου δώσει ο χρήστης και τα αποθηκεύω στον πίνακα Β ελέγχοντας ώστε οι αριθμοί να είναι ακέραοι.
 
Για ι από 1 μέχρι 100
  Εμφάνισε "Δώσε αριθμό"
  Διάβασε Β[ι] 
 
! Ελέγχουμε ώστε ο αριθμός να είναι ακέραιος
 
  Όσο Β[ι] <> Α_Μ(Β[ι]) επανάλαβε
    Εμφάνισε "Ο αρίθμός που έδωσες δεν είναι ακέραιος ξαναδώσε!"
    Διάβασε Β[ι] 
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
!Αρχικοποιούμε των πίνακα των συχνοτήτων ο οποίος θα έχει μέγεθος όσο και το πλήθος των διαφορετικών αριθμών του πίνακα Β, δηλαδή 20.
 
Για ι από 1 μέχρι 20 
  ΠΙΝ_ΣΥΧΝ[ι] ← 0
Τέλος_επανάληψης
 
! Προσπελαύνουμε κάθε στοιχείο του πίνακα Β και αυξάνω την αντίστοιχη θέση του πίνακα ΠΙΝ_ΣΥΧΝ κατά ένα.
 
Για ι από 1 μέχρι 100
  ΠΙΝ_ΣΥΧΝ[ Β[ι]] ← ΠΙΝ_ΣΥΧΝ[ Β[ι]] + 1
Τέλος_επανάληψης
 
! Εμφανίζουμε τον πίνακα συχνοτήτων
Για ι από 1 μέχρι 20 
Εμφάνισε "Το ", ι, " εφμανίζεται ", ΠΙΝ_ΣΥΧΝ[ι], " φορές"
Τέλος_επανάληψης
 
Τέλος Πίνακας_Συχνοτήτων_Ακεραίων