Σάββατο, 20 Οκτωβρίου 2018

Οι καλλιέργειες του μπαρμπα-Νικόλα

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

Η παραγωγή των αγροτικών προϊόντων του μπαρμπα-Νικόλα αυξήθηκε δραματικά τον τελευταίο χρόνο. Γι' αυτό τον λόγο θέλησε πλέον να καταγράφει κάποιες πληροφορίες γι' αυτά ψηφιακά και χρειάζεται την βοήθεια σας. Θέλει να γράψετε έναν αλγόριθμο, ο οποίος 

α) Να περιέχει τμήμα δηλώσεων των μεταβλητών

β) Να αποθηκεύει σε έναν πίνακα ΠΡ[4] τα ονόματα των προϊόντων που παράγει ο Μπαρμπα-Νικόλας και σε έναν πίνακα ΕΜΠ[10] τα ονόματα των 10 εμπόρων που αγοράζουν τα προϊόντα του.

γ) Να αποθηκεύει σε έναν πίνακα ΠΑΡ[4,10] τα χρήματα που πήρε για κάθε προϊόν από τους 10 εμπόρους που τα πούλησε.

δ) Να εμφανίζει τα συνολικά χρήματα που πήρε από κάθε προϊόν.

ε) Να εμφανίσετε το όνομα του έμπορου καθώς και το όνομα του προϊόντος που έδωσε τα λιγότερα χρήματα.

στ) Να εμφανίζει το προϊόν με την μεγαλύτερη ζήτηση.  

Η άσκηση συμμετέχει στο διαγωνισμό "Σας πάμε σινεμά"

Επιμέλεια: Γιώργος Αλεξόπουλος

 

Λύση Άσκησης: 
 
ΠΡΟΓΡΑΜΜΑ Μπαρμπα_Νικόλας
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, j, ι_ΜΙΝ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡ[4], ΕΜΠ[10], ον_πρ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΣΧΡ[4], ΠΑΡ[4, 10], ΜΑΧ, ΜΙΝ
ΑΡΧΗ
!Ερώτημα β
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ "Δώσε το όνομα του προϊόντος"
    ΔΙΑΒΑΣΕ ΠΡ[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ "Δώσε το όνομα του εμπόρου"
    ΔΙΑΒΑΣΕ ΕΜΠ[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα γ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΓΡΑΨΕ "Δώσε τα χρήματα"
      ΔΙΑΒΑΣΕ ΠΑΡ[ι, j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα δ
!Θα υπολογίσουμε το άθροισμα ανά γραμμή
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
    ΣΧΡ[ι] <- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
      ΣΧΡ[ι] <- ΣΧΡ[ι] + ΠΑΡ[ι, j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ "Τα συνολικά χρήματα που πήρες Μπαρμπα-Νικόλα από το ", ΠΡ[ι], " είναι ", ΣΧΡ[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα ε
!Θα υπολογίσουμε το ΜΙΝ ανα στήλη.
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10
    ΜΙΝ <- ΠΑΡ[1, j] 
    ι_ΜΙΝ <- 1
    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 4
      ΑΝ ΠΑΡ[ι, j] < ΜΙΝ ΤΟΤΕ
        ΜΙΝ <- ΠΑΡ[ι, j] 
        ι_ΜΙΝ <- ι
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ ΕΜΠ[j], ΠΡ[ι_ΜΙΝ] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα στ
  ΜΑΧ <- ΣΧΡ[1] 
  ον_πρ <- ΠΡ[1] 
  ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 4
    ΑΝ ΣΧΡ[ι] > ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- ΣΧΡ[ι] 
      ον_πρ <- ΠΡ[ι] 
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΓΡΑΨΕ "Το προϊόν με την μεγαλύτερη ζήτηση είναι ", ον_πρ
 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ