Σάββατο, 20 Οκτωβρίου 2018

Μετρώντας τους φοιτητές (Εξετ. 2007 - Εσπ.)

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 


  1. Σε ένα πανεπιστημιακό τμήμα εισήχθησαν κατόπιν γενικών εξετάσεων 235 φοιτητές προερχόμενοι από τη ΤΕΧΝΟΛΟΓΙΚΗ ή τη ΘΕΤΙΚΗ κατεύθυνση. Να αναπτύξετε αλγόριθμο, ο οποίος:

Α. Για καθένα από τους 235 φοιτητές διαβάζει:



  • το ονοματεπώνυμό του,

  • τα μόρια εισαγωγής του,

  • την κατεύθυνσή του, η οποία μπορεί να είναι «ΤΕΧΝΟΛΟΓΙΚΗ» ή «ΘΕΤΙΚΗ», ελέγχοντας την εγκυρότητα εισαγωγής της

και καταχωρεί τα δεδομένα αυτά σε τρεις πίνακες.


Β. Υπολογίζει και εμφανίζει:



  1. το μέσο όρο των μορίων εισαγωγής των φοιτητών που προέρχονται από τη ΤΕΧΝΟΛΟΓΙΚΗ κατεύθυνση.

  2. το ποσοστό των φοιτητών που προέρχονται από τη ΤΕΧΝΟΛΟΓΙΚΗ κατεύθυνση.

  3. την κατεύθυνση, από την οποία προέρχεται ο φοιτητής με τα περισσότερα μόρια εισαγωγής (να θεωρήσετε ότι δεν υπάρχει περίπτωση ισοβαθμίας).

Γ. τα ονοματεπώνυμα των φοιτητών που προέρχονται από τη ΤΕΧΝΟΛΟΓΙΚΗ κατεύθυνση, για τους οποίους τα μόρια εισαγωγής τους είναι περισσότερα από το μέσο όρο των μορίων εισαγωγής των φοιτητών που προέρχονται από τη ΤΕΧΝΟΛΟΓΙΚΗ κατεύθυνση. 


Επιμέλεια: Εξ. 2007 -  Εσπ.

Λύση Άσκησης: 

 


Αλγόριθμος Θέμα_3ο

! Θέμα 3α

Για i από 1 μέχρι 235

  Εμφάνισε "Δώσε ονοματεπώνυμο και μόρια του ", i, " φοιτητή:"

  Διάβασε όνομα[i], μόρια[i] 

  Εμφάνισε "Δώσε την κατεύθυνση του: "

  Αρχή_επανάληψης

    Διάβασε κατεύθυνση[i] 

  Μέχρις_ότου κατεύθυνση[i] = "ΤΕΧΝΟΛΟΓΙΚΗ" ή κατεύθυνση[i] = "ΘΕΤΙΚΗ"

Τέλος_επανάληψης

! Θέμα 3β1 και 3β2

μ_ο ← 0

μ ← 0

Για i από 1 μέχρι 235

  Αν κατεύθυνση[i] = "ΤΕΧΝΟΛΟΓΙΚΗ" τότε

    μ_ο ← μ_ο + μόρια[i] 

    μ ← μ + 1

  Τέλος_αν

Τέλος_επανάληψης

μ_ο ← μ_ο/ μ

Εμφάνισε "Μέσος όρος μορίων τεχνολογικής κατεύθυνσης: ", μ_ο

ποσοστό ← μ* 100/ 235

Εμφάνισε "Ποσοστό φοιτητών τεχνολογικής κατεύθυνσης: ", ποσοστό, "%"

!Θέμα 3β3

max ← μόρια[1] 

θέση ← 1

Για i από 2 μέχρι 235

  Αν max < μόρια[i] τότε

    max ← μόρια[i] 

    θέση ← i

  Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε "Κατεύθυνση φοιτητή με περισσότερα μόρια:", κατεύθυνση[θέση] 

!Θέμα 3β4

Εμφάνισε "Ονοματεπώνυμα φοιτητών με μόρια πάνω από το μέσο όρο"

Εμφάνισε "της τεχνολογικής κατεύθυνσης"

Για i από 1 μέχρι 235

  Αν κατεύθυνση[i] = "ΤΕΧΝΟΛΟΓΙΚΗ" και μόρια[i] > μ_ο τότε

    Εμφάνισε όνομα[i] 

  Τέλος_αν

Τέλος_επανάληψης

Τέλος Θέμα_3ο