Παρασκευή, 17 Αυγούστου 2018

Κάλαντα Πρωτοχρονιάς

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

 

Η Πρωτοχρονιά πλησιάζει και μια ομάδα παιδιών που θα πει τα κάλαντα θέλει την βοήθεια σας ώστε να βγάλει περισσότερα χρήματα!!!

Ο αλγόριθμος θα διαβάζει σε έναν πίνακα Δ[150] τις διευθύνσεις των 150 σπιτιών που επισκέφθηκαν στα χριστουγεννιάτικα κάλαντα και σε ένα πίνακα ΧΡ[150] τα χρήματα που πήραν από κάθε σπίτι. Ο αλγόριθμος να υπολογίζει και να εμφανίζει:

α) τη διεύθυνση ή τις διευθύνσεις από τα σπίτια που τους έδωσαν τα περισσότερα χρήματα.

β) τη διεύθυνση ή τις διευθύνσεις από τα σπίτια που τους έδωσαν τα λιγότερα χρήματα.

γ) να διαβάζει μια διεύθυνση από τον χρήστη και να εμφανίζει το ποσό των χρημάτων που πήραν από την συγκεκριμένη διεύθυνση. Σε περίπτωση που δεν βρεθεί να εμφανίζει κατάλληλο μήνυμα. 

δ) τα παιδιά θέλουνε να δώσουν το ποσό των 100 ευρώ για την ενίσχυση του Χαμόγελου του παιδιού (http://www.hamogelo.gr/). Να τους εμφανίσει κατάλληλο μήνυμα αν θα καταφέρουν το στόχο τους ή όχι. 

Σημείωση: Θεωρήστε ότι η διεύθυνση που ψάχνουν τα παιδιά στο ερώτημα γ είναι μοναδική.

Επιμέλεια: mstamos.gr

 

Λύση Άσκησης: 
 
Αλγόριθμος Χριστούγεννα
 
Για ι από 1 μέχρι 150
  Εμφάνισε "Δώσε τη διεύθυνση του ", ι, " σπιτιού."
  Διάβασε Δ[ι] 
  Εμφάνισε "Δώσε τα χρήματα τα οποία πήρατε."
  Διάβασε ΧΡ[ι] 
Τέλος_επανάληψης
 
!Ερώτημα α,β
ΜΑΧ ← ΧΡ[1] 
ΜΙΝ ← ΧΡ[1] 
 
Για ι από 2 μέχρι 150
  Αν ΧΡ[ι] > ΜΑΧ τότε
    ΜΑΧ ← ΧΡ[ι] 
  αλλιώς_αν ΧΡ[ι] < ΜΙΝ τότε
    ΜΙΝ ← ΧΡ[ι] 
  Τέλος_αν
Τέλος_επανάληψης
 
Για ι από 1 μέχρι 150
  Αν ΧΡ[ι] = ΜΑΧ τότε
    Εμφάνισε Δ[ι] 
  αλλιώς_αν ΧΡ[ι] = ΜΙΝ τότε
    Εμφάνισε Δ[ι] 
  Τέλος_αν
Τέλος_επανάληψης
 
!Ερώτημα γ
Εμφάνισε "Δώσε την διεύθυνση που θέλεις να ψάξεις."
Διάβασε δ_αν
 
ι ← 1
βρέθηκε ← 0
 
Όσο ι ≤ 150 και βρέθηκε = 0 επανάλαβε
  Αν δ_αν = Δ[ι] τότε
    Εμφάνισε "Τα χρήματα που πήρατε από αυτό το σπίτι είναι ", ΧΡ[ι] 
    βρέθηκε ← 1
  αλλιώς
    ι ← ι + 1
  Τέλος_αν
Τέλος_επανάληψης
Αν βρέθηκε = 0 τότε
  Εμφάνισε "Η διεύθυνση που πληκτρολογήσατε δεν υπάρχει"
Τέλος_αν
 
!Ερώτημα δ
συν_χρημάτων ← 0
Για ι από 1 μέχρι 150
  συν_χρημάτων ← συν_χρημάτων + ΧΡ[ι] 
Τέλος_επανάληψης
 
Αν συν_χρημάτων > 100 τότε
  Εμφάνισε "Μπράβο παιδιά καταφέρατε το στόχο σας!!!"
αλλιώς
  Εμφάνισε "Μπράβο παιδιά άξιζε η προσπάθεια που κάνατε! Και του χρόνου!"
Τέλος_αν
 
Τέλος Χριστούγεννα