Δευτέρα, 10 Δεκεμβρίου 2018

Η Χιονάτη και οι 7 νάνοι

Βαθμός Δυσκολίας:
4/5
Εκφώνηση Ασκησης: 

Η Χιονάτη και οι 7 νάνοι αποφασίζουν να ανοίξουν κατάστημα με παγωμένο γιαούρτι. Η κακιά Βασίλισσα το μαθαίνει και για να εκδικηθεί την Χιονάτη για την χαμένη της ομορφιά, βάζει στόχο να τους ανταγωνιστεί και να τους καταστρέψει. Να γραφεί πρόγραμμα το οποίο:

Α)Να διαβάζει και να καταχωρεί σε δισδιάστατο πίνακα τα ετήσια έσοδα της Χιονάτης και σε άλλο της κακιάς Βασίλισσας.

Β)Να βρίσκει ποιο μήνα είχε τα περισσότερα κέρδη κάθε κατάστημα και να τα συγκρίνει μεταξύ τους. Αν είχε περισσότερα έσοδα η Βασίλισσα να εμφανίζει μήνυμα ‘’Είσαι η ομορφότερη σ΄ όλο το βασίλειο’’.

Γ)Να καλεί υποπρόγραμμα το οποίο να εμφανίζει πόσο παγωμένο γιαούρτι μήλου λείπει από το κατάστημα των νάνων.

Δ)Να καλεί υποπρόγραμμα το οποίο να διαβάζει και να ελέγχει αν το κατάστημα των νάνων έχει επισκεφτεί ο Λιχούδης κι αν η απάντηση είναι ναι να καλεί υποπρόγραμμα που θα υπολογίζει πόσα κέρδισαν από αυτόν.

Ε)Αν το κατάστημα της Χιονάτης έχει τα περισσότερα κέρδη να εμφανίζει μήνυμα ‘’Ζήσανε αυτοί καλά κι εμείς καλύτερα’’, στην αντίθετη περίπτωση να εμφανίζει το μήνυμα ‘’Ζήσαν αυτοί καταραμμένοι κι εμείς στεναχωρημένοι’’.(Υποθέστε ότι τα κέρδη δεν μπορούν να είναι ίσα).

 

Υποπρόγραμμα ερωτήματος γ: Η Χιονάτη λατρεύει το παγωμένο γιαούρτι μήλο. Κάθε μήνα που το δικό τους κατάστημα έχει περισσότερα έσοδα από της κακιάς μάγισσας τότε τρώει μόνο 5 κιλά γιαούρτι την ημέρα, ενώ σε διαφορετική περίπτωση στεναχωριέται και τρώει 7 κιλά.(Από τον πρώτο μέχρι τον έκτο μήνα οι μήνες που έχουν ζυγό αριθμό έχουν 30 ημέρες ενώ οι μήνες οι οποίοι έχουν μονό αριθμό έχουν 31 ημέρες. Από τον έβδομο μέχρι τον δωδέκατο μήνα οι μήνες που έχουν ζυγό αριθμό έχουν 31 ημέρες ενώ οι μήνες οι οποίοι έχουν μονό αριθμό έχουν 30 ημέρες. Ο Φλεβάρης έχει 28 ημέρες.)

 

Υποπρόγραμμα ερωτήματος δ: Ο Λιχούδης λατρεύει το παγωμένο γιαούρτι και συμπαθεί τους νάνους. Κάθε φορά που πάει στο κατάστημα των νάνων, τον ρωτάει ο Σοφός αν είναι χαρούμενος ή στεναχωρημένος. Αν η απάντηση είναι χαρούμενος τότε τρώει 2 κιλά από κάθε γεύση με επικάλυψη τρούφας ενώ αν η απάντηση είναι στεναχωρημένος τότε τρώει μόνο 3 κιλά απλής γεύσεως χωρίς τρούφα.(Θεωρήστε πως όλες οι γεύσεις είναι 3).

 

Φυσική γεύση

Κιλά

Τιμή(€)

 

0.7-1.0

0.8

 

1.0-2.0

1.0

 

2.0-3.0

2.0

 

3.0 και

3.5

 

Σοκολατένια γεύση

Κιλά

Τιμή(€)

 

0.7-1.0

1.0

 

1.0-2.0

2.0

 

2.0-3.0

3.5

 

3.0 και

4.0

 

 

Φραουλένια γεύση

Κιλά

Τιμή(€)

 

0.7-1.0

2.0

 

1.0-2.0

3.5

 

2.0-3.0

4.0

 

3.0

5.0

 

Χρέωση τρούφας: +0.50€

Επιμέλεια: Αντωνοπούλου Κωνσταντίνα

                                                                                                Βακρατσά Άννα

H άσκηση συμμετέχει στον διαγωνισμό 1 Άσκηση = 1 Tablet.

 

Βαθμολογία Κριτών

Χρήστος Τσάλης Γιάννης Καψάλης Φανή Αναγνώστου Δημήτρης Τζανέκας Μίλτος Στάμος
8 10 10 9 10

 

Συνολική Βαθμολογία Κριτών                47

Συνολική Βαθμολογία από τα Likes        11

Συνολική Βαθμολογία                       58

 

Λύση Άσκησης: 

 

ΠΡΟΓΡΑΜΜΑ ΚΑ

ΜΕΤΑΒΛΗΤΕΣ:

     ΑΚΕΡΑΙΕΣ:i,j

     ΠΡΑΓΜΑΤΙΚΕΣ:Χ[30,12],Κ[30,12],ΣΧ[30],ΣΚ[30],ΜΑΧΧ,ΜΑΧΚ,ΚΕΡΔΗΧ,ΚΕΡΔΗΚ

     ΧΑΡΑΚΤΗΡΕΣ:ΛΙΧΟΥΔΗΣ

ΑΡΧΗ

     ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30

      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12

         ΔΙΑΒΑΣΕ Χ[I,j], Κ[I,j]

      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30

       ΣΧ[i]<- 0

       ΣΚ[i]<- 0

       ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12

          ΣΧ[i]<- ΣΧ[i] + X[i,j]

          ΣΚ[i]<- ΣΚ[i] + Κ[i.j]

      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΜΑΧΧ[i]<- ΣΧ[1]

MAXK[i]<- ΣΚ[1]

ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 12

 ΑΝ ΣΚ[i] > ΜΑΧΚ ΤΟΤΕ

     MAXK<-ΣΚ[i]

ΤΕΛΟΣ_ΑΝ

ΑΝ ΣΧ[i] > ΜΑΧΧ ΤΟΤΕ

   ΜΑΧΧ<-ΣΚ[i]

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ ΜΑΧΚ>ΜΑΧΧ ΤΟΤΕ

ΓΡΑΨΕ «ΕΙΣΑΙ Η ΟΜΟΡΦΟΤΕΡΗ ΑΠΟ ΟΛΕΣ»

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ ΜΗΛΟ(αθρ)

ΔΙΑΒΑΣΕ ΛΙΧΟΥΔΗΣ

ΑΝ ΛΙΧΟΥΔΗΣ= “ΝΑΙ” ΤΟΤΕ

ΓΡΑΨΕ ΚΕΡ.ΛΙΧΟΥΔΗΣ(χρ)

ΤΕΛΟΣ_ΑΝ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 12

ΚΕΡΔΗΧ<- ΚΕΡΔΗΧ +ΣΧ[i]

ΚΕΡΔΗΚ<- ΚΕΡΔΗΚ +ΣΚ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ ΚΕΡΔΗΧ>ΚΕΡΔΗΚ ΤΟΤΕ

ΓΡΑΨΕ «ΖΗΣΑΝ ΑΥΤΟΙ ΚΑΛΑ ΚΙ ΕΜΕΙΣ ΚΑΛΥΤΕΡΑ»

ΑΛΛΙΩΣ

ΓΡΑΨΕ «ΖΗΣΑΝ ΑΥΤΟΙ ΚΑΤΑΡΑΜΜΕΝΟΙ ΚΙ ΕΜΕΙΣ ΣΤΕΝΑΧΩΡΗΜΕΝΟΙ»

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

 

ΣΥΝΑΡΤΗΣΗ  ΜΗΛΟ(αθρ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: i, γλ

ΠΡΑΓΜΑΤΙΚΕΣ: αθρ

ΑΡΧΗ

αθρ <-0

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6

ΑΝ ΣΧ[i]> ΣΚ[i] ΤΟΤΕ

ΑΝ imod2=0 ΤΟΤΕ

    Γλ<- 5*30

   ΑΝ i=2 ΤΟΤΕ

      Γλ<-7*29

  ΤΕΛΟΣ_ΑΝ

    αθρ<- αθρ +γλ

ΑΛΛΙΩΣ

  γλ<- 5*31

  αθρ<- αθρ +γλ

ΤΕΛΟΣ_ΑΝ

ΑΛΛΙΩΣ

ΑΝ imod2<>0 ΤΟΤΕ

 γλ<- 7*30

aθρ<- αθρ+γλ

ΑΛΛΙΩΣ

  Γλ<-7*31

 aθρ<- αθρ +γλ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 

ΓΙΑ i ΑΠΟ 7 ΜΕΧΡΙ 12 ΤΟΤΕ

ΑΝ ΣΧ[i]> ΣΚ[i] ΤΟΤΕ

ΑΝ imod2=0 ΤΟΤΕ

    γλ<- 5*31

    αθρ <- αθρ +γλ

ΑΛΛΙΩΣ

  Γλ<- 5*30

  αθρ <- αθρ +γλ

ΤΕΛΟΣ_ΑΝ

ΑΛΛΙΩΣ

ΑΝ imod2<>0 ΤΟΤΕ

 γλ <- 7*31

αθρ <- αθρ+γλ

ΑΛΛΙΩΣ

  γλ <-7*30

 αθρ <- αθρ +γλ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΜΗΛΟ<- αθρ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

ΣΥΝΑΡΤΗΣΗ ΚΕΡ_ΛΙΧΟΥΔΗΣ(χρ):ΠΡΑΓΜΑΤΙΚΉ

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ:ΧΡ

ΧΑΡΑΚΤΗΡΕΣ:ΑΠ

ΑΝ ΑΠ=’’ΧΑΡΟΥΜΕΝΟΣ’’ ΤΟΤΕ

   ΧΡ<- 2*2+2*4+2*3.5+0.5

ΑΛΛΙΩΣ

  ΧΡ<-3*3.5

ΤΕΛΟΣ_ΑΝ

ΚΕΡ_ΛΙΧΟΥΔΗΣ<-ΧΡ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ