Πέμπτη, 24 Μαΐου 2018

Φωτοβολταϊκά κανείς;! (Εξετ. 2012 - Ημ.)

Βαθμός Δυσκολίας:
4/5
Εκφώνηση Ασκησης: 

Μια εταιρεία ασχολείται με εγκαταστάσεις φωτοβολταϊκών συστημάτων, με τα οποία οι πελάτες της έχουν τη δυνατότητα αφενός να παράγουν ηλεκτρική ενέργεια για να καλύπτουν τις ανάγκες της οικίας τους, αφετέρου να πωλούν την πλεονάζουσα ενέργεια προς 0,55€/kWh, εξασφαλίζοντας επιπλέον έσοδα. Η εταιρεία αποφάσισε να ερευνήσει τις εγκαταστάσεις που πραγματοποίησε την προηγούμενη χρονιά σε δέκα (10) πελάτες που βρίσκονται ο καθένας σε διαφορετική πόλη της Ελλάδας.

Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:

∆1.

α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδα 1)

β. Να διαβάζει για κάθε πελάτη το όνομά του και το όνομα της πόλης στην οποία διαμένει και να τα αποθηκεύει στον δισδιάστατο πίνακα ΟΝ[10,2].

γ. Να διαβάζει το ποσό της ηλεκτρικής ενέργειας σε kWh που παρήγαγαν τα φωτοβολταϊκά συστήματα κάθε πελάτη, καθώς και το ποσό της ηλεκτρικής ενέργειας που κατανάλωσε κάθε πελάτης για κάθε μήνα του έτους, και να τα αποθηκεύει στους πίνακες Π[10,12] για την παραγωγή και Κ[10,12] για την κατανάλωση αντίστοιχα (δεν απαιτείται έλεγχος εγκυρότητας των δεδομένων).

∆2.  Να υπολογίζει την ετήσια παραγωγή και κατανάλωση ανά πελάτη καθώς και τα ετήσια έσοδά του σε ευρώ (€). Θεωρήστε ότι για κάθε πελάτη η ετήσια παραγόμενη ηλεκτρική ενέργεια είναι μεγαλύτερη ή ίση της ενέργειας που έχει 
καταναλώσει. 


∆3.  Να εμφανίζει το όνομα της πόλης στην οποία σημειώθηκε η μεγαλύτερη παραγωγή ηλεκτρικού 
ρεύματος. 


∆4.  Να καλεί κατάλληλο υποπρόγραμμα με τη βοήθεια του οποίου θα εμφανίζονται τα ετήσια έσοδα κάθε πελάτη κατά φθίνουσα σειρά. Να κατασκευάσετε το 
υποπρόγραμμα που χρειάζεται για το σκοπό αυτό. 


∆5.  Να εμφανίζει τον αριθμό του μήνα με τη μικρότερη παραγωγή ηλεκτρικής ενέργειας. Θεωρήστε ότι υπάρχει μόνο ένας τέτοιος μήνας.

Επιμέλεια: Εξετ. 2012 - Ημ. 

Λύση Άσκησης: 

ΠΡΟΓΡΑΜΜΑ θέμαδ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ι, j, Θ_ΜΙΝ, θ_μαχ
 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[10, 2]
 ΠΡΑΓΜΑΤΙΚΕΣ: Π[10, 12], Κ[10, 12], ΕΠ[10], ΕΚ[10], ΜΑΧ, ΕΤ_ΕΣ[10], Σ_ΠΑΡ[12], ΜΙΝ

ΑΡΧΗ

 ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε όνομα'
    ΔΙΑΒΑΣΕ ΟΝ[ι, 1]
    ΓΡΑΨΕ 'Δώσε πόλη'
    ΔΙΑΒΑΣΕ ΟΝ[ι, 2]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
     ΓΡΑΨΕ 'Δώσε ποσό παραγωγής'
     ΔΙΑΒΑΣΕ Π[ι, j]
     ΓΡΑΨΕ 'Δώσε ποσό κατανάλωσης'
     ΔΙΑΒΑΣΕ Κ[ι, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΕΠ[ι] <- 0
    ΕΚ[ι] <- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
     ΕΠ[ι] <- ΕΠ[ι] + Π[ι, j]
     ΕΚ[ι] <- ΕΚ[ι] + Κ[ι, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΕΤ_ΕΣ[ι] <- (ΕΠ[ι] - ΕΚ[ι])*0.55
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΜΑΧ <- ΕΠ[1]
 θ_μαχ <- 1

 ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 10
    ΑΝ ΕΠ[ι] > ΜΑΧ ΤΟΤΕ
     ΜΑΧ <- ΕΠ[ι]
     θ_μαχ <- ι
    ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΡΑΨΕ 'Το όνομα της πόλης με την μεγαλύτερη παραγωγή ηλεκτρικού ρεύματος είναι ', ΟΝ[θ_μαχ, 2]


 ΚΑΛΕΣΕ ΕΜ_ΔΕΔ(ΕΤ_ΕΣ)

 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
    Σ_ΠΑΡ[j] <- 0
    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
     Σ_ΠΑΡ[j] <- Σ_ΠΑΡ[j] + Π[ι, j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΜΙΝ <- Σ_ΠΑΡ[1]
 Θ_ΜΙΝ <- 1

 ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 12
    ΑΝ Σ_ΠΑΡ[ι] < ΜΙΝ ΤΟΤΕ
     ΜΙΝ <- Σ_ΠΑΡ[ι]
     Θ_ΜΙΝ <- ι
    ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΡΑΨΕ 'Ο μήνας με την μικτρότερη παραγωγή είναι ο ', Θ_ΜΙΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ