Παρασκευή, 17 Αυγούστου 2018

Εργοστάσια Σοκολάτας

Βαθμός Δυσκολίας:
4/5
Εκφώνηση Ασκησης: 

Ένας επιχειρηματίας έχει εφτά εργοστάσια παραγωγής σοκολάτας και θέλει να καταγράφει τα δεδομένα της εταιρείας ψηφιακά. Για το λόγο αυτό θα χρειαστεί πρόγραμμα, το οποίο θα κάνει τα εξής: 

α) θα αποθηκεύει σε έναν πίνακα Δ[7] τις διευθύνσεις των 7 εργοστασίων.

β) θα καλεί υποπρόγραμμα ΕΙΣ με το οποίο θα γεμίζει τον πίνακα ΠΑΡ_ΣΟΚ. Ο πίνακας θα περιέχει την παραγωγή σοκολάτας κάθε εργοστασίου για κάθε μήνα του έτους. Ο επιχειρηματίας κλείνει τα εργοστάσια Ιούλιο - Αύγουστο λόγο μειωμένης κατανάλωσης σοκολάτας. Συνεπώς, γι' αυτούς τους μήνες θα πρέπει να εισαχθεί η τιμή μηδέν.

γ) θα καλεί συνάρτηση η οποία θα υπολογίζει τη συνολική παραγωγή για κάθε εργοστάσιο.

δ) θα καλεί υποπρόγραμμα, το οποίο θα αποθηκεύσει σε ένα πίνακα ΑΠ τις ποσοστιαίες απώλειες της παραγωγής (λόγο μεταφορών κλπ) για κάθε εργοστάσιο. Αν ένα εργοστάσιο έχει απώλειες 10% στον πίνακα, θα πρέπει να αποθηκεύεται το 10.

ε) αν κάθε σοκολάτα πωλείται προς 0.8 ευρώ να υπολογίσετε τα συνολικά έσοδα του επιχειρηματία.

Επιμέλεια: mstamos.gr

Λύση Άσκησης: 

 

ΠΡΟΓΡΑΜΜΑ Εργοστάσια_Σοκολάτας
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: Δ[7] 
  ΠΡΑΓΜΑΤΙΚΕΣ: ΑΠ[7], μικτά_έσοδα, συν_εσοδα
  ΑΚΕΡΑΙΕΣ: ΠΑΡ_ΣΟΚ[7, 12], ι, j, ΣΠΑΡ[7] 
 
ΑΡΧΗ
 
!Ερώτημα α
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    ΓΡΑΨΕ "Δώσε τη διεύθυνση του εργοστασίου"
    ΔΙΑΒΑΣΕ Δ[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα β
  ΚΑΛΕΣΕ ΕΙΣ(ΠΑΡ_ΣΟΚ) 
 
!Ερώτημα γ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    ΣΠΑΡ[ι] <- ΥΠΟΛ(ΠΑΡ_ΣΟΚ, ι) 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
!Ερώτημα δ
  ΚΑΛΕΣΕ ΚΑΤ_ΑΠ(ΑΠ) 
 
!Ερώτημα ε
  συν_εσοδα <- 0
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    μικτά_έσοδα <- ΣΠΑΡ[ι]* 0.8
    συν_εσοδα <- συν_εσοδα + ( μικτά_έσοδα - (μικτά_έσοδα* ΑΠ[ι])) 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΓΡΑΨΕ "Τα συνολικά έσοδα του επιχειρηματία είναι ", συν_εσοδα
 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 
!Η διαδικασία του ερωτήματος β
ΔΙΑΔΙΚΑΣΙΑ ΕΙΣ(ΠΑΡ_ΣΟΚ) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, j, ΠΑΡ_ΣΟΚ[7, 12] 
ΑΡΧΗ
 
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
      ΑΝ j <> 7 ΚΑΙ j <> 8 ΤΟΤΕ
        ΓΡΑΨΕ "Δώσε την παραγωγή του ", ι, " μήνα."
        ΔΙΑΒΑΣΕ ΠΑΡ_ΣΟΚ[ι, j] 
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ "Το εργοστάσιο μένει κλειστό Ιούλιο-Αύγουστο"
        ΠΑΡ_ΣΟΚ[ι, j] <- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
 
!Η συνάρτηση του γ ερωτήματος
ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ(ΠΑΡ_ΣΟΚ, ι): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, j, ΠΑΡ_ΣΟΚ[7, 12], αθρ
ΑΡΧΗ
  αθρ <- 0
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
    αθρ <- αθρ + ΠΑΡ_ΣΟΚ[ι, j] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΥΠΟΛ <- αθρ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
 
!Η διαδικασία του δ ερωτήματος
ΔΙΑΔΙΚΑΣΙΑ ΚΑΤ_ΑΠ(ΑΠ) 
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΑΠ[7] 
  ΑΚΕΡΑΙΕΣ: ι
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 7
    ΓΡΑΨΕ "Δώσε το ποσοστό απωλειών του εργοστασίου"
    ΔΙΑΒΑΣΕ ΑΠ[ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ