Σάββατο, 16 Ιουνίου 2018

Έρευνα Super Market

Βαθμός Δυσκολίας:
2/5
Εκφώνηση Ασκησης: 

Πριν από 5 χρόνια, σε ένα super market της περιοχής πραγματοποιήθηκε μία έρευνα. Σκοπός της ήταν να καταγράψει και να διαπιστώσει ποιο προϊόν της ήταν το πιο φθηνό. Η έρευνα ξεκίνησε από έναν υπάλληλο του καταστήματος, ο οποίος θέλησε να μελετήσει τις διακυμάνσεις της τιμής του γάλακτος. Να γραφεί αλγόριθμος που θα διαβάζει το είδος του γάλακτος, την τιμή και την ποσότητα του σε ml που διατίθεται και αφού υπολογίσει την αξία ανά ml, να βρίσκει ποιο γάλα έχει την χαμηλότερη τιμή και ποια είναι αυτή. Η διαδικασία αυτή να γίνεται για συγκεκριμένο πλήθος από γάλατα το οποίο ο αλγόριθμος θα το δέχεται από τον χρήστη.

Επιμέλεια: Παναγιώτα Στόγια

H άσκηση συμμετέχει στον διαγωνισμό 1 Άσκηση = 1 Tablet.

 

Βαθμολογία Κριτών

Χρήστος Τσάλης Γιάννης Καψάλης Φανή Αναγνώστου Δημήτρης Τζανέκας Μίλτος Στάμος
7.2 6 7 6 7

 

Συνολική Βαθμολογία Κριτών                33.2

Συνολική Βαθμολογία από τα Likes        5

Συνολική Βαθμολογία                       38.2

 

Λύση Άσκησης: 

Αλγόριθμος Γάλα
Διάβασε Ν
Διάβασε είδος, τιμή, ml
τιμή_ανα_ml ← τιμή/ml
min ← τιμή_ανα_ml
min_είδος ← είδος
Για ι από 2 μέχρι Ν
  Διάβασε είδος, τιμή, ml
  τιμή_ανα_ml ← τιμή/ml
  Αν τιμή_ανα_ml < min τότε
    min ← τιμή_ανα_ml
    min_είδος ← είδος
  Τέλος_αν
Τέλος_επανάληψης
Εμφάνισε min, min_είδος
Τέλος Γάλα