Παρασκευή, 19 Ιανουαρίου 2018

Εδώ ο καλός Ψαράς

Βαθμός Δυσκολίας:
4/5
Εκφώνηση Ασκησης: 

 

'Ενας ψαράς θέλει να καταγράφει στον υπολογιστή του τις ψαριές του για ένα χρόνο ώστε να κάνει απολογισμό στο τέλος της χρονιάς. Σας ζητά να γράψετε αλγόριθμο ο οποίος: 

Α) να αποθηκεύει σε ένα μονοδιάστατο πίνακα ΨΑΡ[50] τα ονόματα των 50 διαφορετικών ψαριών που ψαρεύει.

Β) να αποθηκεύει σε ένα δισδιάστατο πίνακα ΚΙΛ[50,12]  τα κιλά κάθε είδους ψαριού για κάθε ένα απο τους 12 μήνες (όταν δεν έχει καθόλου κιλά από το συγκεκριμένο ψάρι βάζει τη τιμή 0).

Γ) να υπολογίζει το μήνα που ψάρεψε τα περισσότερα κιλά ψαριών συνολικά.

Δ) να εμφανίζει για κάθε ψάρι το μήνα που έκανε τη μεγαλύτερη ψαριά.

Ε) αν ο ψαράς πουλούσε το κιλό τη "ΣΚΟΡΠΙΝΑ" 18 ευρώ κατά μέσο όρο, να του εμφανίζεται το ποσό των χρημάτων που πήρε μόνο απο αυτό το ψάρι τους μήνες Ιούνιο-Ιούλιο-Αύγουστο (είναι ο 6ος, 7ος και 8ος μήνας). Θεωρείστε ότι η "ΣΚΟΡΠΙΝΑ" υπάρχει σίγουρα στα ψάρια.

Στ) να εμφανίζει το πλήθος των μηνών που δεν ψάρεψε καθόλου "ΣΚΟΡΠΙΝΑ".

Επιμέλεια: mstamos.gr 

Λύση Άσκησης: 
 
Αλγόριθμος Ψαρας
 
!Ερώτημα Α,Β
Για ι από 1 μέχρι 50
  Εμφάνισε "Πληκτρολόγησε το όνομα του ", ι, " ψαριού"
  Διάβασε ΨΑΡ[ι] 
  Για j από 1 μέχρι 12
    Εμφάνισε "Πληκτρολόγησε τα κιλά του ψαριού για τον ", j, " μήνα."
    Διάβασε ΚΙΛ[ι, j] 
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
!Ερώτημα Γ
Για j από 1 μέχρι 12
  ΣΥΝΨ[j] ← 0
  Για ι από 1 μέχρι 50
    ΣΥΝΨ[j] ← ΣΥΝΨ[j] + 1
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
ΜΑΧ ← ΣΥΝΨ[1] 
μην_ΜΑΧ ← 1
Για ι από 2 μέχρι 12
  Αν ΣΥΝΨ[ι] > ΜΑΧ τότε
    ΜΑΧ ← ΣΥΝΨ[ι] 
    μην_ΜΑΧ ← ι
  Τέλος_αν
Τέλος_επανάληψης
 
Εμφάνισε "Ο μήνας με τις περισσότερες συνολικά ψαριές είναι ο ", μην_ΜΑΧ
 
!Ερώτημα Δ
Για ι από 1 μέχρι 50
  ΜΑΧ ← ΚΙΛ[ι, 1] 
  μην_ΜΑΧ ← 1
  Για j από 1 μέχρι 12
    Αν ΚΙΛ[ι, j] > ΜΑΧ τότε
      ΜΑΧ ← ΚΙΛ[ι, j] 
      μην_ΜΑΧ ← j
    Τέλος_αν
  Τέλος_επανάληψης
  Εμφάνισε "Ο μήνας που έκανες τη μεγαλύτερη ψαριά για το ", ΨΑΡ[ι], " είναι ο ", μην_ΜΑΧ
Τέλος_επανάληψης
 
!Ερώτημα Ε
θέση ← 0
ι ← 1
Όσο ι ≤ 50 και θέση = 0 επανάλαβε
  Αν ΨΑΡ[ι] = "ΣΚΟΡΠΙΝΑ" τότε
    θέση ← ι
  Τέλος_αν
  ι ← ι + 1
Τέλος_επανάληψης
 
συν_κιλ ← 0
Για j από 6 μέχρι 8
  συν_κιλ ← συν_κιλ + ΚΙΛ[θέση, j] 
Τέλος_επανάληψης
 
χρήματα_σκορπ ← συν_κιλ* 18
 
Εμφάνισε "Τα συνολικά χρήματα που πήρες από την ΣΚΟΡΠΙΝΑ είναι ", χρήματα_σκορπ
 
!Ερώτημα ΣΤ
πλ ← 0
Για j από 1 μέχρι 12
  Αν ΚΙΛ[θέση, j] = 0 τότε
    πλ ← πλ + 1
  Τέλος_αν
Τέλος_επανάληψης
 
Εμφάνισε "Η ΣΚΟΡΙΠΙΝΑ δεν είχε καθόλου ψαριά ", πλ, " μήνες."
 
Τέλος Ψαρας