Σάββατο, 20 Οκτωβρίου 2018

Διαγωνισμός ΑΕΠΠ

Βαθμός Δυσκολίας:
2/5
Εκφώνηση Ασκησης: 

 

Σε ένα φροντιστήριο ο καθηγητής της ανάπτυξης εφαρμογών πήρε την πρωτοβουλία και ανακοίνωσε στους μαθητές της Γ λυκείου ότι θα γίνει ένας διαγωνισμός και ο νικητής θα κερδίσει 2 εισιτήρια για σινεμά. Οι μαθητές που δήλωσαν συμμετοχή στον διαγωνισμό ήταν 30 και διαγωνίστηκαν σε μία γραπτή εξέταση και σε μία προφορική. Ο βαθμολογητής και στις δύο εξετάσεις ήταν ο Μίλτος Στάμος.

Να γραφεί αλγόριθμος ο οποίος:

α) να διαβάζει τα ονόματα των μαθητών και να τα αποθηκεύει σε έναν πίνακα

β) να διαβάζει τους βαθμούς που πήρε κάθε μαθητής στην προφορική και στη γραπτή εξέταση και να τα αποθηκεύει σε μονοδιάστατους πίνακες.

γ) να υπολογίζει το μέσο όρο των βαθμών κάθε μαθητή και να τον αποθηκεύει σε ένα μονοδιάστατο πίνακα.

δ) να εμφανίζει τα ονόματα και δίπλα τους βαθμούς των μαθητών ταξινομημένα κατά φθίνουσα σειρά με βάση τους βαθμούς. Σε περίπτωση ισοβαθμίας η ταξινόμηση των ονομάτων να γίνει αλφαβητικά.

ε) Να εμφανίζει το νικητή του διαγωνισμού, όπου είναι ο μαθητής με το μεγαλύτερο μέσο όρο.

Η άσκηση συμμετέχει στο διαγωνισμό "Σας πάμε σινεμά"

Επιμέλεια: Μελανίτης Βασίλης και Μπουζούκης Παντελής

Λύση Άσκησης: 

 

Αλγόριθμος Διαγωνισμός_Σινεμά
 
!Α,Β ερώτημα
Για ι από 1 μέχρι 30
  Γράψε "Δώσε το όνομα του μαθητή"
  Διάβασε Μ[ι] 
  Γράψε "Δώσε την βαθμολογία στην προφορική εξέταση"
  Διάβασε Πρ[ι] 
  Γράψε "Δώσε την βαθμολογία στην γραπτή εξέταση"
  Διάβασε Γρ[ι] 
Τέλος_επανάληψης
 
!Γ ερώτημα
Για ι από 1 μέχρι 30
  ΜΒ[ι] ← (Πρ[ι] + Γρ[ι])/2
Τέλος_επανάληψης
 
!Δ ερώτημα
Για ι από 2 μέχρι 30
  Για j από 30 μέχρι 1 με_βήμα -1
    Αν ΜΒ[j] > ΜΒ[j - 1] τότε
      Αντιμετάθεσε ΜΒ[j], ΜΒ[j - 1] 
      Αντιμετάθεσε Μ[j], Μ[j - 1] 
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
Για ι από 1 μέχρι 30
  Γράψε Μ[ι], ΜΒ[ι] 
Τέλος_επανάληψης
 
!Ε ερώτημα
Γράψε "Ο νικητής του διαγωνισμού που θα πάει σινεμα είναι ο ", Μ[1] 
 
Τέλος Διαγωνισμός_Σινεμά