Παρασκευή, 20 Απριλίου 2018

Δείκτης Μάζας του ανθρώπινου Σώματος (Εξετ. 2003 - Ημ )

Βαθμός Δυσκολίας:
3/5
Εκφώνηση Ασκησης: 

 

Ο Δείκτης Μάζας του ανθρώπινου Σώματος (ΔΜΣ) υπολογίζεται από το βάρος (Β) σε χλγρ. και το ύψος (Υ) σε μέτρα με τον τύπο ΔΜΣ = Β/Υ^2. Ο προηγούμενος τύπος ισχύει για άτομα άνω των 18 ετών. Το άτομο, ανάλογα με την τιμή του ΔΜΣ, χαρακτηρίζεται σύμφωνα με τον παρακάτω πίνακα:

 
ΔΜΣ <18,5 "αδύνατο άτομο"
18,5<=ΔΜΣ<25 "κανονικό άτομο"
25<=ΔΜΣ<30 "βαρύ άτομο"
ΔΜΣ>=30 "υπέρβαρο άτομο"


Να γράψετε πρόγραμμα το οποίο:

α) Να διαβάζει την ηλικία, το βάρος και το ύψος του ατόμου

β) Εάν η ηλικία είναι μεγαλύτερη των 18 ετών τότε: 1. Να υπολογίζει το ΔΜΣ 2. Να ελέγχει την τιμή του ΔΜΣ από τον παραπάνω πίνακα και να εμανίζει τον αντίστοιχο χαρακτηρισμό.

γ) Εάν η ηλικία είναι μικρότερη ή ίση των 18 ετών, τότε να εμανίζει το μήνυμα "δεν ισχύει ο δείκτης ΔΜΣ"

Επιμέλεια: Εξ. 2003 - Ημ

Λύση Άσκησης: 

 

ΠΡΟΓΡΑΜΜΑ ΔΜΣ_ΕΞΗΜ2003

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: κόστος_ασφάλισης
ΑΚΕΡΑΙΕΣ: ηλικία, κυβισμός
ΧΑΡΑΚΤΗΡΕΣ: τύπος_οχήματος

ΑΡΧΗ

ΓΡΑΨΕ 'Δώσε την ηλικία σου'

ΔΙΑΒΑΣΕ ηλικία

ΓΡΑΨΕ 'Δώσε τον τύπο του οχήματος'

ΔΙΑΒΑΣΕ τύπος_οχήματος

ΓΡΑΨΕ 'Δώσε κυβισμό'

ΔΙΑΒΑΣΕ κυβισμός

ΑΝ τύπος_οχήματος = 'ΔΙΚΥΚΛΟ' ΤΟΤΕ

ΑΝ κυβισμός <= 125 ΤΟΤΕ

κόστος_ασφάλισης <- 100

ΑΛΛΙΩΣ

κόστος_ασφάλισης <- 140

ΤΕΛΟΣ_ΑΝ

ΑΛΛΙΩΣ

ΑΝ κυβισμός <= 1400 ΤΟΤΕ

κόστος_ασφάλισης <- 400

ΑΛΛΙΩΣ_ΑΝ κυβισμός <= 1800 ΤΟΤΕ

κόστος_ασφάλισης <- 500

ΑΛΛΙΩΣ

κόστος_ασφάλισης <- 700

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΑΝ ηλικία >= 18 ΚΑΙ ηλικία <= 24 ΤΟΤΕ

κόστος_ασφάλισης <- κόστος_ασφάλισης + (κόστος_ασφάλισης* 0.1) 

ΤΕΛΟΣ_ΑΝ

ΓΡΑΨΕ 'Το ετήσιο κόστος είναι ', κόστος_ασφάλισης

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ