Παρασκευή, 15 Δεκεμβρίου 2017

2 Fast 2 Furious

Βαθμός Δυσκολίας:
2/5
Εκφώνηση Ασκησης: 

Στο Μανχάταν γίνεται μια έκθεση αγωνιστικών αμαξιών. Σε αυτή λαμβάνουνε μέρος 50 αμάξια και 10 κριτές, οι οποίοι βαθμολογούν κάθε αυτοκίνητο ως προς το επίπεδο "φτιαξίματός" του. Τα αμάξια βαθμολογούνται από τους κριτές με τιμές από 1 έως 5. 

Να γίνει αλγόριθμος ο οποίος:

Α) θα καταχωρεί σε ένα μονοδιάστατο πίνακα ΑΜ[50] τα ονόματα των αμαξιών και σε ένα δισδιάστατο ΒΑΘ[50,10] τις βαθμολογίες των κριτών

Β) θα δημιουργεί ένα μονοδιάστατο πίνακα ΣΒΑΘ[50], στον οποίο θα καταχωρείται η συνολική βαθμολογία που έλαβε κάθε αμάξι. 

Γ) θα υπολογίζει και θα εμφανίζει τα 3 αμάξια με τη μεγαλύτερη βαθμολογία καθώς και το τελευταίο της κατάταξης.

Η άσκηση συμμετέχει στο διαγωνισμό "Σας πάμε σινεμά"

Επιμέλεια: Μάνος Κοσμάς και Κατερίνα Ζαφείρη

Λύση Άσκησης: 
 
Αλγόριθμος Too_Fast_2_Furious
 
!Ερώτημα Α
Για ι από 1 μέχρι 50
  Γράψε "Δώσε το όνομα του αμαξιού"
  Διάβασε ΑΜ[ι] 
  Για j από 1 μέχρι 10
    Αρχή_επανάληψης
      Γράψε "Δώσε τη βαθμολογία του ", j, " κριτή."
      Διάβασε ΒΑΘ[ι, j] 
    Μέχρις_ότου ΒΑΘ[ι, j] ≥ 1 και ΒΑΘ[ι, j] ≤ 5
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
!Ερώτημα Β
Για ι από 1 μέχρι 50
  ΣΒΑΘ[ι] ← 0
  Για j από 1 μέχρι 10
    ΣΒΑΘ[ι] ← ΣΒΑΘ[ι] + ΒΑΘ[ι, j] 
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
!Ερώτημα Γ
Για ι από 2 μέχρι 50
  Για j από 50 μέχρι ι με_βήμα -1
    Αν ΣΒΑΘ[j] > ΣΒΑΘ[j - 1] τότε
      Αντιμετάθεσε ΣΒΑΘ[j], ΣΒΑΘ[j - 1] 
      Αντιμετάθεσε ΑΜ[j - 1], ΑΜ[j] 
 
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
 
Εμφάνισε "Τα 3 αμάξια με την μεγαλύτερη βαθμολογία είναι: "
Για ι από 1 μέχρι 3
  Εμφάνισε ΑΜ[ι] 
Τέλος_επανάληψης
 
Εμφάνισε "Το αμάξι με την μικρότερη βαθμολογία είναι ", ΑΜ[50] 
Τέλος Too_Fast_2_Furious